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Elegir un tipo de proyecto paquete, 
Permitir documentación roxygen con

Tools > Project Options > Build 
Tools
Guía Roxygen en

Help > Roxygen Quick 
Reference

File > New Project > 

New Directory > R Package

Compartir
Proyecto con
Colaboradores

Colaboradores 
activos

Seleccionar
Versión de 
R

Iniciar nueva
Sesión R en 
proyecto actual

Cerrar
Sesión R  
en proyecto

JHT

RStudio guarda: historial de 
llamadas, espacio de trabajo 
y directorio de trabajo 
asociado con un proyecto. 
Recarga cada uno cuando 
vuelve a abrir un proyecto.

Nombre del 
proyecto 
actual

View(<data>) abre una hoja de cálculo como una 
vista del conjunto de datos

Ordenar 
por 
valor

Filtrar filas por 
valor o por rango 
de valores

Buscar 
un valor

El panel Visor muestra contenido HTML, como 
aplicaciones Shiny, informes RMarkdown y 

visualizaciones interactivas

Detener 
Shiny app

Publicar a shinyapps.io, 
rpubs, RSConnect, …

Refres
car

RStudio abre documentación en un panel de ayuda 
dedicado

Página Inicial 
de enlaces 
útiles

Buscar dentro 
de archivo de 
ayuda

Buscar 
archivo 
de ayuda

El administrador de paquetes GUI  lista todos 
los paquetes instalados

Eliminar 
de 
librería

Instalar 
Paquete

Modificar 
Paquete

Crear librería de paquete 
reproducible para tu 
proyecto

RStudio abre gráficos en un panel 
dedicado a gráficos

Navegar  
gráficos 
recientes

Abrir en 
Ventana

Exportar 
gráfico

Eliminar 
gráfico

Eliminar 
todos los 
gráficos

Version
de 
paquete 
instalado

Examinar 
variables en 
entorno de 
ejecución

Abrir rastreo para
examinar las funciones 
que R llamó antes que el
error occurriera

Entrar a modo
depuración
desde origen del
error

Cliquear cerca 
del  número de 
línea para  
agregar/sacar  
un punto de 
parada.

Seleccionar 
función en 
rastreo para 
depurar

La línea 
resaltada 
indica dónde 
se pausó la 
ejecución.

Correr comandos 
en entorno donde la 
ejecución está 
pausada

Pasar por 
código de a 
una línea 
por vez

Entrar y salir 
de las 
funciones a 
ejecutar

Reanudar 
la 
ejecución

Salir de 
modo 
depuración

Abrir archivos Shiny, 

R Markdown, knitr, 
Sweave, LaTeX, .Rd y 
más en Panel Fuente

Chequear 
ortografía

Rende-
rizar 
salida

Elegir 
formato 
de 
salida

Elegir 
ubicación 
Salida

Insertar 
chunk de

codigo

Saltar a 
chunk
anterior

Saltar a 
chunk
siguiente

Correr 
líneas 
seleccio
nadas

Publicar 
al servido

Mostrar 
esque-
ma de 
archivo

Setear
opciones 
de knitr
chunk

Correr este 
y todos los  
los códigos 
chunk
previos

Correr 
este chunk

Saltar a 
chunk

RStudio reconoce que archivos llamados 
app.R, server.R, ui.R, y global.R corresponden 
a una app shiny

Correr 
app

Elegir 
ubicacion
para ver 
app

Publicar a 
shinyapps.i
o or server

Manejar 
cuentas
publicaci
on

Acceso a guía markdown en: 

Help > Markdown Quick Reference

Stage 
files:

Mostrar 
diferencias 
archivos

Commit 
staged 
files

Push/Pull  
a remoto

Ver 
Historia

Rama 
actual

Activar desde Tools > Project Options > Git/SVN

Abrir terminal 
para 
comandos

Buscar 
dentro del 
entorno

Sintaxis resaltada 
basado en extensión 
del archivo

Diagnóstico de código que aparece en 
el margen. Desplacese sobre el símbolo 
de diagnóstico para más detalles

Tab completa el  nombre 
de función, ruta de 
archivo, argumentos, y 
más.
Fragmento de código 
Multi-lenguaje para usar 
rápidamente un bloque 
de código común.

Abrir en 
nueva 
ventana

Salvar Encontrar y 
reemplazar

Compilar  
como 
notebook

Correr 
código  
seleccionado

Correr 
nuevamente 
código previo

Instrucción 
Source con o 
sin Echo

Mostrar
esquema 
archivo

Saltar a función en archivo Cambiar tipo archivo

Navegar en 
tabulaciónes

Un explorador de archivo apuntando al 
directorio de trabajo. Cliquear sobre el 
archivo o directorio para abrir.

Ruta al directorio mostrado

Cargar 
archivo

Crear 
carpe
-ta

Borrar 
archivo

Renom-
brar
archivo

Cambiar  
directorio

Muestra los objetos 
guardados por tipo con 
una breve descripción

Ver código 
fuente de la 
función

Ver en 
visor de 
datos

Cargar 
área de 
trabajo

Salvar área 
de trabajo

Importar
datos con
asistente

Eliminar todos 
los objetos 
salvados

Mostrar 
objetos como 
lista o grilla

Elija el entorno para mostrar de la 
lista de entornos principales

Historia de  
comandos ante-
riores para 
correr/copiar

Mostrar presentación 
diapositivas .RPres
File > New  File > 

R Presentation

Directorio 
de trabajo

Maximizar/ 
minimizar 
paneles
Arrastrar 
bordes de
paneles

JHT

Cursores de 
usuarios 
compartidos File > New 

Project

Oprima para 
ver historia de 
comandos

Selección Múltiple de cursores / 
columnas con Alt + mouse drag.

Documentos y Apps Soporte R

Sistema de Proyectos

Modo Depuración Control de Version con Git o SVN

Escritura de Paquetes

• Agregado
• Eliminado
• Modificad
• Renombr
• Sin 

seguir

A

D

M

R

?

Cliquear para cargar
paquete con library().
Descliquear para descargar
package con detach()

Abrir con debug(), browser(), o un breakpoint. RStudio abrirá
el modo depuración cuando encuentre un punto de parada
mientras ejecuta el código.
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3 NAVEGAR X 

CODIGO

Windows /Linux Mac

Ir a Archivo/Función Ctrl+. Ctrl+.

Doblado Seleccionado Alt+L Cmd+Option+L

Desdobl. Seleccionado Shift+Alt+L Cmd+Shift+Option+L

Doblar Todo Alt+O Cmd+Option+O

Desdoblar Todo Shift+Alt+O Cmd+Shift+Option+O

Ir a Linea Shift+Alt+G Cmd+Shift+Option+G

Saltar a Shift+Alt+J Cmd+Shift+Option+J

Conmutar a tab Ctrl+Shift+. Ctrl+Shift+.

Tab Previo Ctrl+F11 Ctrl+F11

Tab Siguiente Ctrl+F12 Ctrl+F12

Primer tab Ctrl+Shift+F11 Ctrl+Shift+F11

Ultimo tab Ctrl+Shift+F12 Ctrl+Shift+F12

Navegar atrás Ctrl+F9 Cmd+F9

Navegar adelante Ctrl+F10 Cmd+F10

Saltar a Llaves Ctrl+P Ctrl+P

Selección dentro Llaves Ctrl+Shift+Alt+E Ctrl+Shift+Option+E

Selección para buscar Ctrl+F3 Cmd+E

Buscar en Archivos Ctrl+Shift+F Cmd+Shift+F

Buscar siguiente F3 / Ctrl+G Cmd+G

Buscar Anterior Shift+F3 /

Ctrl+Shift+G

Cmd+Shift+G

Saltar a Palabra Ctrl+ ← / → Option+← / →

Saltar a Inicio/Fin Ctrl+↑ / ↓ Cmd+↑ / ↓

Cambia Esquema Ctrl+Shift+O Cmd+Shift+O

8 DOCUMENTOS Y APPS Windows/Linux Mac

Vista PreviaHTML(Markdown, 

etc.)

Ctrl+Shift+K Cmd+Shift+K

Knitear Documento (knitr) Ctrl+Shift+K Cmd+Shift+K

Compilar Notebook Ctrl+Shift+K Cmd+Shift+K

Compilar PDF (TeX & Sweave) Ctrl+Shift+K Cmd+Shift+K

Insertar chunk (Sweave & Knitr) Ctrl+Alt+I Cmd+Option+I

Insertar sección código Ctrl+Shift+R Cmd+Shift+R

Re-procesar región anterior Ctrl+Shift+P Cmd+Shift+P

Correr documento actual Ctrl+Alt+R Cmd+Option+R

Correr de inicio a línea actual Ctrl+Alt+B Cmd+Option+B

Correr la sección código actual Ctrl+Alt+T Cmd+Option+T

Correr código Sweave/Rmd ant. Ctrl+Alt+P Cmd+Option+P

Correr chunk actual Ctrl+Alt+C Cmd+Option+C

Correr chunk siguiente Ctrl+Alt+N Cmd+Option+N

Sincroniz.Editor & Vista 

Prev.PDF 

Ctrl+F8 Cmd+F8

7 HACER PAQUETES Windows/Linux Mac

Construir y recargar Ctrl+Shift+B Cmd+Shift+B

Cargar todo(devtools) Ctrl+Shift+L Cmd+Shift+L

Testear Paquete (Escritorio) Ctrl+Shift+T Cmd+Shift+T

Testear Paquete (Web) Ctrl+Alt+F7 Cmd+Opt+F7

Chequear Paquete Ctrl+Shift+E Cmd+Shift+E

Documentar Paquete Ctrl+Shift+D Cmd+Shift+D

6 VERSION CONTROL Windows/LinuxMac
Mostrar diferencias Ctrl+Alt+D Ctrl+Option+D

Confirmar cambios Ctrl+Alt+M Ctrl+Option+M

Mover por vista de diferencias Ctrl+↑ / ↓ Ctrl+↑ / ↓

Stage/Unstage (Git) Spacebar Spacebar

Stage/Unstage y moverse al 

siguiente

Enter Enter

5 DEPURAR CODIGO Windows/Linux Mac

Marcar punto de parada Shift+F9 Shift+F9

Ejecutar Siguiente Linea F10 F10

Paso dentro Función Shift+F4 Shift+F4

Terminar Función/Bucle Shift+F6 Shift+F6

Continuar Shift+F5 Shift+F5

Parar Depuración Shift+F8 Shift+F8

2 CORRER CODIGO Windows/Linux Mac
Buscar comando en historial Ctrl+↑ Cmd+↑
Navegar en historial ↑ / ↓ ↑ / ↓

Mover cursor al inicio de línea Home Cmd+←

Move cursor al fin de línea End Cmd+→

Cambiar de directorio trabajo Ctrl+Shift+H Ctrl+Shift+H

Interrumpir comando actual Esc Esc

Limpiar consola Ctrl+L Ctrl+L

Salir de Sesión (solo desktop) Ctrl+Q Cmd+Q

Reiniciar Sesión R Ctrl+Shift+F10 Cmd+Shift+F10

Correr linea/selección actual Ctrl+Enter Cmd+Enter

Correr current (retain cursor) Alt+Enter Option+Enter

Correr desde actual al fin Ctrl+Alt+E Cmd+Option+E

Correr  def. función actual Ctrl+Alt+F Cmd+Option+F

Fuente a archivo Ctrl+Alt+G Cmd+Option+G

Fuente archivo actual Ctrl+Shift+S Cmd+Shift+S

Fuente con echo Ctrl+Shift+Enter Cmd+Shift+Enter

1 DISEÑO Windows/LinuxMac
Mover foco a Editor Fuente Ctrl+1 Ctrl+1

Mover foco a Consola Ctrl+2 Ctrl+2

Mover foco a Ayuda Ctrl+3 Ctrl+3

Mostrar Historial Ctrl+4 Ctrl+4

Mostrar Archivos Ctrl+5 Ctrl+5

Mostrar Gráficos Ctrl+6 Ctrl+6

Mostrar Paquetes Ctrl+7 Ctrl+7

Mostrar Entorno Ctrl+8 Ctrl+8

Mostrar Git/SVN Ctrl+9 Ctrl+9

Mostrar Build Ctrl+0 Ctrl+0
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Gráfico anterior Ctrl+Alt+F11 Cmd+Option+F11

Gráfico siguiente Ctrl+Alt+F12 Cmd+Option+F12
Show Keyboard Shortcuts Alt+Shift+K Option+Shift+K

RSP extiende el servidor de código abierto 
con una licencia comercial, soporte, y más:
• abre y procesa múltiples sesiones R a la vez

• configura tus recursos para mejorar performance

• edita el mismo proyecto simultáneamente con otros

• mira que están haciendo tú y otros en el servidor

• cambia fácilmente entre versiones de R diferentes

• Se integra con tu autenticación, autorización y prácticas de 
auditoria

Descarga gratis una versión de evaluación por 45 días en:

www.rstudio.com/products/rstudio-server-pro/

POR QUÉ RSTUDIO SERVER PRO?4 ESCRIBIR CODIGO Windows /Linux Mac

Tratar de completar Tab or Ctrl+Space Tab or Cmd+Space

Navegar x candidatos ↑ / ↓ ↑ / ↓

Aceptar candidato Enter, Tab, o → Enter, Tab, o →

Descartar candidatos Esc Esc

Deshacer Ctrl+Z Cmd+Z

Rehacer Ctrl+Shift+Z Cmd+Shift+Z

Cortar Ctrl+X Cmd+X

Copiar Ctrl+C Cmd+C

Pegar Ctrl+V Cmd+V

Seleccionar Todo Ctrl+A Cmd+A

Eliminar Línea Ctrl+D Cmd+D

Seleccionar Shift+[Arrow] Shift+[Arrow]

Seleccionar Palabra Ctrl+Shift+← / → Option+Shift+ ← / →

Selec. a Inicio de Línea Alt+Shift+← Cmd+Shift+←

Selec. a Fin de Línea Alt+Shift+→ Cmd+Shift+→

Selec.Pag. Arriba/Abajo Shift+PageUp/Down Shift+PageUp/Down

Selecc.a Inicio/Fin Shift+Alt+ ↑ / ↓ Cmd+Shift+↑ / ↓

Eliminar Palabra Izq. Ctrl+Backspace Ctrl+Opt+Backspace

Eliminar Palabra Der. Option+Delete

Eliminar hasta Fin Linea Ctrl+K

Eliminar hasta Inicio 

Linea

Option+Backspace

Identar Tab (at start of line) Tab (at start of line)

Des-identar Shift+Tab Shift+Tab

Tira línea hasta cursor Ctrl+U Ctrl+U

Tira linea desde cursor Ctrl+K Ctrl+K

Inserta text tirado Ctrl+Y Ctrl+Y

Insertar asigna ‘<-’ Alt+- Option+-

Insertar %>% Ctrl+Shift+M Cmd+Shift+M

Mostrar Ayuda función F1 F1

Mostrar fuente función F2 F2

Nuevo documento Ctrl+Shift+N Cmd+Shift+N

Nuevo documento Chro Ctrl+Alt+Shift+N Cmd+Shift+Opt+N

Abrir documento Ctrl+O Cmd+O

Salvar documento Ctrl+S Cmd+S

Cerrar documento Ctrl+W Cmd+W

Cerrar documento Chro Ctrl+Alt+W Cmd+Option+W

Cerrar todos docum. Ctrl+Shift+W Cmd+Shift+W

Extraer función Ctrl+Alt+X Cmd+Option+X

Extraer variable Ctrl+Alt+V Cmd+Option+V

Reidentar lines Ctrl+I Cmd+I

(Des)Comentar lines Ctrl+Shift+C Cmd+Shift+C

Reflow Comment Ctrl+Shift+/ Cmd+Shift+/

Reformat Selection Ctrl+Shift+A Cmd+Shift+A

Seleccionar entre [ ] Ctrl+Shift+E Ctrl+Shift+E

Mostrar Diagnosticos Ctrl+Shift+Alt+P Cmd+Shift+Opt+P

Trasponer Letras Ctrl+T

Mover Linea Arr/Abajo Alt+↑ / ↓ Option+↑ / ↓

Copia Lineas Arr/Abajo Shift+Alt+↑ / ↓ Cmd+Option+↑ / ↓

Agr NuevoCursor Arriba Ctrl+Alt+Up Ctrl+Option+Up

Agr Nuevo Cursor Abajo Ctrl+Alt+Down Ctrl+Option+Down

Cursor Activo Arriba Ctrl+Alt+Shift+Up Ctrl+Option+Shift+Up

Cursor Activo Abajo Ctrl+Alt+Shift+Down Ctrl+Opt+Shift+Down

Encontrar y Reemplazar Ctrl+F Cmd+F

Usar Selecc. Encontrar 

Reemplazar y Encontrar   

Ctrl+F3

Ctrl+Shift+J

Cmd+E

Cmd+Shift+J
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